iMagazine

Jak sprawdzić, które aplikacje przestaną nam działać pod MacOS 10.15 Catalina?

14/08/2019, 13:48 · · · 11

Nowa wersja MacOS – Catalina – będzie debiutowała już niedługo, a tymczasem może się okazać, że Wasze oprogramowanie nie jest pod nią przygotowane. Nie chodzi tutaj o wyeliminowanie bugów czy innych problemów – Catalina rezygnuje z wspierania aplikacji 32-bitowych i te po prostu nie będą się uruchamiały.

Jak sprawdzić, które aplikacje przestaną działać?

Najprościej będzie kliknąć w logo Apple w górnym lewym rogu ekranu i wybrać z listy pierwszą pozycję About this Mac / O tym Macu.

Następnie należy kliknąć w przycisk System Report…

Alternatywnie możecie po prostu uruchomić Spotlighta (Cmd + Space) i wpisać tam System Information, aby uruchomić tę aplikację.

Po jej uruchomieniu należy z lewej strony kliknąć w Software → Applications / Oprogramowanie → Programy. Następnie możecie posortować sobie listę aplikacji za pomocą kolumny 64-Bit (Intel) – jeśli widnieje tam No / Nie, to ten program nie będzie działał.

Jak widać, obecnie pakiet Adobe Creative Cloud nie jest przygotowany dla Cataliny. Warto o takich aplikacjach pamiętać, bo może się okazać, że po uaktualnieniu zostaniecie bez narzędzi do pracy. Polecam w takiej sytuacji się wstrzymać, aż deweloperzy nadrobią swoje zaległości.

Jeśli używacie obecnie MacOS Mojave, to podczas uruchamiania aplikacji 32-bitowych zobaczycie okienko, jak to powyżej – to ostrzeżenie, że aplikacja jest 32-bitowa i nie będzie działała pod Cataliną.

A tymczasem…

11

Wojtek Pietrusiewicz

Wydawca, fotograf, podróżnik, podcaster – niekoniecznie w tej kolejności. Lubię espresso, mechaniczne zegarki i zwinne samochody. Niedawno rozpocząłem prowadzenie kursów Lightrooma i fotografii na Pikselowe.pl – zapraszam.


11
Dodaj komentarz

avatar
5 Comment threads
6 Thread replies
10 Followers
 
Most reacted comment
Hottest comment thread
10 Comment authors
PawełVampUppsssYcboajmak Recent comment authors
  Subscribe  
najnowszy najstarszy oceniany
Powiadom o
jojo
Gość
jojo

Nie mam na liście żadnego programu 32 bit. (poza dwoma od Apple).
Swoją drogą, mógłbyś zamieścić zrzuty z polskiej wersji systemu, a przynajmniej sprawdzić jakie nazwy mają opcje w naszym języku.

Wojtek
Gość
Wojtek

Czyli masz na liście dwie aplikacje 32-bitowe. 😜

Przyciski są w tym samym miejscu, a System Information to Informacje o Systemie. Nie używam PL w swoich OS i nie zamierzam zaczynać. 😉

jojo
Gość
jojo

Te dwa programy od Apple znikną wraz z nową wersją systemu, więc problemu nie ma.
Oczywiście możesz zamieszczać screeny nawet po chińsku. W końcu artykuły piszesz dla swojej przyjemności, a nie po to, żeby miały jakąkolwiek wartość, prawda? 😜

Woo
Użytkownik
Woo

Przełączenie na język polski na chwilę i powrót do angielskiego potrafią namieszać w ustawieniach. Zrobiłem parę razy, więcej nie zamierzam. Nie ma sensu dla tak prostego komunikatu. Bez przesady, nie ma tu nic, czego nie można zrozumieć bez korzystania z tłumacza google. Poza tym angielski do dzisiejsza Lingua Franca. Porównywanie angielskiego do chińskiego to tani chwyt erystyczny.

Vamp
Gość
Vamp

Może zamiast marnować czas na negowanie dobrych wskazówek, które Wojtek przekazuje to weź słownik w dłoń i chociażby elementarne podstawy angielskiego opanuj.

Ycbo
Gość
Ycbo

To pisz dla anglików, moze któryś będzie chciał to czytać.

Uppsss
Gość
Uppsss

Dzis uzywanie j.angielskiego jest tym czym był j.francuski dla ‚elit’ w XIXw.
Śmieszne to i straszne.

Kkk
Gość
Kkk

czyli u mnie nie będzie działać tuxera… to niedobrze

Woo
Użytkownik
Woo

Co prawda jestem zmuszony przez Nvidię do zatrzymania się na High Sierra ale w moim zestawieniu mam kilkadziesiąt aplikacji 32-bitowych. Ciekawe, kiedy deweloperzy darmowego softu podgonią? Nie wyobrażam sobie życia bez XLD, PYM Playera, SubCleanera itp.
Koszmary z instalacją różnych rozszerzeń już w HS prowokują mnie do pytania: quo vadis Apple?

ajmak
Gość
ajmak

Sprawdziłem i mam pytanie za 100 punktów:
Jaki jest zamiennik Crazy Bump?

Paweł
Użytkownik
Paweł

Czy będzie można jakoś dodać nieoficjalnie obsługę 32-bit? Mam 59 aplikacji, które nie wspierają 64-bitów i to powstrzymuje mnie przed aktualizacją do Cataliny a tym samym do iOS i iPad OS żeby mieć zgodność bazy zdjęć oraz do WatchOS 6, bo nie mogę go zainstalować z poziomu iOS 12.